Nextcloud .ocdata

SSL ist deaktiviert! Aktivieren Sie SSL für diese Sitzung, um eine sichere Verbindung herzustellen.

Es gibt 12 Antworten in diesem Thema. Der letzte Beitrag () ist von Michdi.

    Nextcloud .ocdata

    Guten Nachmittag liebe Community,
    ich nutze eine Nextcloud Instanz auf meiner Diskstation und diese lief auch gut. Nun kann ich mich nicht mehr anmelden, weil angeblich die .ocdata Datei im /data Ordner fehlt. Diese existiert, wird aber irgendwie nicht erkannt.
    Kann mir wer helfen?

    Data directory (/volume1/web/cloud/data) is invalid
    Please check that the data directory contains a file ".ocdata" in its root.


    Die beste maschinelle Übersetzung der Welt - DeepL Übersetzer
    Alle Zitate, die ich seit dem 1.9.2017 übersetzt habe, wurden vollautomatisch mit DeepL übersetzt.



    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Michdi“ ()

    @Kameo
    Die Berechtigungen habe ich mit einem Code von Nextcloud nun gefixt. Leider bekomme ich immer noch die .ocdata Meldung. Diese verschwindet auch nicht, obwohl die Datei vorhanden ist.
    Die beste maschinelle Übersetzung der Welt - DeepL Übersetzer
    Alle Zitate, die ich seit dem 1.9.2017 übersetzt habe, wurden vollautomatisch mit DeepL übersetzt.



    Wie sieht den der Inhalt der Datei aus? Kannst du da irgendwelche Abweichungen erkennen zur erstinstallation? Bzw hat dein NAS in der Zeit eine neue IP bekommen und in der ocdata steht eine andere drin?

    EDIT: ist die ocdata evtl schreibgeschützt?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Kameo“ ()

    Wenn du per FTP oder Explorer auf die Datei zugreifen kannst muss es ein internes Config Problem sein.
    Wenn du das nicht geregelt bekommst hilft ja im Endeffekt nur eine Neuinstallation..
    evtl hast du noch ein paar Infos was du vorher gemacht hast?
    Oder hast du sogar ein Backup welches du aufspielen kannst?

    Gerade hier gefunden: es handelt sich hierbei um die ocdata

    https://forum.owncloud.org/viewtopic.php?t=21097 schrieb:

    from this github.com/owncloud/core/searc…a&ref=cmdform&type=Issues, it seems it does not need to contain anything but just need be there.
    So I added it (no data in it), and run once again, but I got an error "failed to update documents".
    I removed it, tried again, added read right to all, and now this is working
    Danke, das Zitat hat nicht funktioniert.

    Weiß du, ob es eine Möglichkeit gibt, Sicherheitsmeldungen zu deaktivieren?

    Ich habe 3 Sicherheitsmeldungen, die irrelevant sind:

    Einige Dateien haben die Integritätsprüfung nicht bestanden. Weiterführende Information findest du in unserer Dokumentation. (Liste der ungültigen Dateien ... / Erneut analysieren…)

    Der "Strict-Transport-Security" HTTP-Header ist nicht auf mindestens "15552000" Sekunden eingestellt. Um die Sicherheit zu erhöhen, empfehlen wir das Aktivieren von HSTS, wie es in den Sicherheitshinweisen erläutert ist.



    Es wurde kein PHP Memory Cache konfiguriert. Zur Erhöhung der Leistungsfähigkeit kann ein Memory-Cache konfiguriert werden. Weitere Informationen findest du in unserer Dokumentation.
    Bitte überprüfe noch einmal die Installationsanleitungen ↗ und kontrolliere das Log auf mögliche Fehler oder Warnungen.


    Die Integritätsprüfung wurde nicht bestanden wegen Synology Systemdateien, der HSTS lässt sich nicht konfigurieren und es wird automatisch auf https geleitet und PHP Memory Cache ist konfiguriert...

    @Kameo
    Die beste maschinelle Übersetzung der Welt - DeepL Übersetzer
    Alle Zitate, die ich seit dem 1.9.2017 übersetzt habe, wurden vollautomatisch mit DeepL übersetzt.



    Ist das eine Meldung von der Synology DS oder Nextcloud?
    Läuft deine Nextcloud auf einer Extra Partition? (evtl Mal testen ob es so geht)
    Hast du den PHP installiert auf der DS?
    Eventuell kannst du ja per PHP Config die Umleitung auf HSTS regeln?

    Michdi schrieb:


    Der "Strict-Transport-Security" HTTP-Header ist nicht auf mindestens "15552000" Sekunden eingestellt. Um die Sicherheit zu erhöhen, empfehlen wir das Aktivieren von HSTS, wie es in den Sicherheitshinweisen erläutert ist.

    Kommt der Webservice (Apache oä.) von Nextcloud oder hättest du den schon vorher auf deinem NAS? (da mal schauen ob du was am HTTP Header drehen kannst)
    Die Meldung ist von Nextcloud.
    Nextcloud läuft wie alles auf volume1. PHP ist installiert als Paket aus dem Paketzentrum mit phpMyAdmin und der Web-Station. Da kann ich nichts verändern, zumindest nicht für die Hauptdomain. In der nginx Config kann ich den HSTS Header verändern, da ist aber alles nach einem Tag zurückgesetzt...

    Ich habe noch keine Option gefunden, da was zu ändern...
    Danke! @Kameo
    Die beste maschinelle Übersetzung der Welt - DeepL Übersetzer
    Alle Zitate, die ich seit dem 1.9.2017 übersetzt habe, wurden vollautomatisch mit DeepL übersetzt.



    In der nginx Config kann ich den HSTS Header verändern, da ist aber alles nach einem Tag zurückgesetzt...
    liegt das evtl daran das du deinem NAS keine feste IP zugeteilt hast?
    Nextcloud läuft wie alles auf volume1.
    evtl Mal auf einer neuen Partition installieren damit es keine Berechtigungsprobleme gibt.
    Das liegt daran, dass der Web-Server von der Diskstation gerne mit Neustarts alles zurücksetzt, so wie er es kennt. Eine neue Partition wäre eigentlich unschön. Ich lasse es sonst erstmal so.

    Trotzdem danke für die Hilfe! @Kameo
    Die beste maschinelle Übersetzung der Welt - DeepL Übersetzer
    Alle Zitate, die ich seit dem 1.9.2017 übersetzt habe, wurden vollautomatisch mit DeepL übersetzt.