Strato Probleme mit Server

SSL ist deaktiviert! Aktivieren Sie SSL für diese Sitzung, um eine sichere Verbindung herzustellen.

Es gibt 17 Antworten in diesem Thema. Der letzte Beitrag () ist von wertherchen.

    Strato Probleme mit Server

    Hallo, ich hoffe ihr könnt mir Helfen bei meinem Problem.

    Ich habe einen vServer bei Strato und wie so oft gibt es Updates von dem Hoster etc... meine Webseiten liefen alle Problemlos mit mühevoller Konfiguration
    und allen Einstellungen. Nun ging ganz Plötzlich die Webseite nicht mehr und der Server war aus.

    Starten des Servers blieb ohne Erfolge nur das Notfall System ging und in den Daten war alles vorhanden. Auf Anfrage von Strato sehe man dort keine Probleme leider sehe
    ich auch keine Probleme da ich leider nicht Verfolgen kann wie der Start abläuft wo eventuelle Fehler auftreten was mir sehr fehlt das Protokoll.

    Strato sagte ich soll eventuell Neuinstallieren oder im Notfallsystem alles neu Kopieren etc...


    Habt ihr noch Ideen was man Probieren könnte oder eventuelle Logdatein Hilfreich sind?
    Hi,

    wieso sollte jemand einen vServer betreiben, wenn er nicht weiß wo die Logfiles gespeichert sind?

    da ich leider nicht Verfolgen kann wie der Start abläuft wo eventuelle Fehler auftreten was mir sehr fehlt das Protokoll

    Wenn du an Logs zum Bootvorgang interessiert bist schau dir die Dateien an:
    /var/log/dmesg.log
    /var/log/boot.log
    /var/log/syslog
    /var/log/boot.msg
    Mach' nen Neustart und schau dir die Files dann mit tail an. Es würde Sinn machen zuvor den Dienst bootlogd zu starten um alle Messages zu speichern (in /var/log/boot).
    Natürlich unter der Voraussetzung dass das ein Linux OS ist (Ubuntu vielleicht), aber die Info hast du ja noch nicht rausgerückt.
    Kommst du über SSH noch auf den Server drauf? Notfallsystem reicht ja dafür.

    Gibt's ne Möglichkeit auf einen Rollback der jüngsten (durch Strato eingespielten) Updates? Wenn Strato das installiert hat (und bestimmt ja nicht nur für dich) müssten ja mehr Leute das Problem haben. Vielleicht hast du aber auch verhunzte Einstellungen gehabt. So oder so, dass bei ausgerollten Updates mal was schief geht kann passieren (ist auch bei guten Hostern schon passiert). Aber im Regelfall können die das im Handumdrehen wieder rückgängig machen.

    Ansonsten Neuinstallation, aber wenn du cool bist hast du ein Snapshot Backup von einem früheren Zeitpunkt. Dateibackup macht Strato ja automatisch für dich (täglich soweit ich weiß).

    Und überdenk' vielleicht ob Strato die richtige Wahl ist, denn ich persönlich bin mit denen gar nicht zufrieden gewesen. Aber das nur am Rand.

    //OffTopic
    @Snickbrack aka GoldwingStudios: wieviele Accounts hast du hier im Forum mittlerweile eigentlich? Das muss ja schon mindestens der Dritte sein.

    Link :thumbup:


    www.marius-gerum.de
    PHP lernen | Programmierung | Sonstiger Krempel
    Zum Blog | PHP lernen | GitHub | Gists | List of awesome

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „Link“ ()

    also der Hoster (Strato) hat ein Update eingespielt und jetzt funktioniert bei dir nix mehr bzw. Server läuft nicht mehr?

    Das kann nicht sein. Dafür würden Sie dir Support bieten (wenn denn sowas auftritt), dann wärst du nämlich nicht der einzige. Die stellen dir nämlich keinen eigenen Server da hin. Deine Umgebung läuft wahrscheinlich in einer VM.

    Wann sollte den was passieren?
    Was passiert denn?
    Was hast du nach dem Update gemacht?
    Wie versuchst du dich auf den Server zu verbinden?

    //Offtopic
    @Link: Das ist "immer noch" der zweite ;)

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Snickbrack“ ()

    Habe nun nachgeschaut auf dem Server für mich als Frau ist das Schwer.

    Log Datein sehe ich keine neu erstellten. Der 22.5 sind die letzten Logs wo bis dahin das System noch ging.

    Ich weis leider kein rat mehr wie ich alles Online bringe :(

    // Weder SSH/noch FTP gehen ohne Notfallsystem
    // Welches Update keine Ahnung habe selber nichts gestartet es gab nur mal eine Wartung von Strato aus bis dahin ging alles.
    // Gibt es möglichkeiten wenn ich den Server Ordner sehe etwas in den Boot vorgang zu schieben was mir mehr auskunft gibt?

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Saphira104“ ()

    Saphira104 schrieb:

    ... auf dem Server für mich als Frau ist das Schwer


    Was soll das denn heißen?
    There is no CLOUD - just other people's computers

    Q: Why do JAVA developers wear glasses?
    A: Because they can't C#

    Daily prayer:
    "Dear Lord, grand me the strength not to kill any stupid people today and please grant me the ability to punch them in the face over standard TCP/IP."
    ​Habe nun nachgeschaut auf dem Server für mich als Frau ist das Schwer.

    So 'ne schwache Ausrede zieht halt gar nicht. Außer der Server verhält sich unterschiedlich je nach Geschlecht der Person die ihn bedient - aus meiner Sicht unwahrscheinlich.

    Interessant wär ja eigentlich in erster Linie, was der Strato Support auf deine Anfrage hin gesagt hat. Die können bei nem abgeschmierten Server ja nicht sagen dass es ihnen egal ist... Hast du denn mit denen telefoniert? Würde ich machen, dann hast du in 5 Minuten wenigstens ne definitive Aussage.
    Kannst du auf ein Snapshot Backup zurückgreifen?

    ​// Gibt es möglichkeiten wenn ich den Server Ordner sehe etwas in den Boot vorgang zu schieben was mir mehr auskunft gibt?

    Möglichkeiten für das Boot logging hab ich ja im vorherigen Post schon ausgeführt.


    Link :thumbup:


    www.marius-gerum.de
    PHP lernen | Programmierung | Sonstiger Krempel
    Zum Blog | PHP lernen | GitHub | Gists | List of awesome

    Strato sagt sie können nichts sehn zu dem Server weder Fernstarten noch eine Diagnose machen

    Das wär ja die Lächerlichkeit, wenn der Hosting-Provider nicht die Verantwortung für seine eigenen Server übernehmen will. Theoretisch haben die ein Rechenzentrum, d.h. die können jederzeit dort hin latschen. Der Typ war einfach ne faule Sau, mit sowas darfst du dich nicht abspeisen lassen.

    Ok das mit dem Backup teste ich jetzt das Problem ich hätte es früher versuchen sollen das vom 28.5 ist das letzte ich teste es mal ob es läuft .

    Ja aber ich glaub das ist dann eher ein Backup auf Dateiebene, kein Disk-, Snapshot oder vhd-backup. Das wird dir nicht helfen den Server wieder zum Laufen zu kriegen, damit kannst du aber zumindest deine Dateien retten.


    Link :thumbup:


    www.marius-gerum.de
    PHP lernen | Programmierung | Sonstiger Krempel
    Zum Blog | PHP lernen | GitHub | Gists | List of awesome

    Klingt eher nach einem fehlerhaften vServer bzw fehlerhaften Config nach dem Update von Strato. Wäre mir aber auch neu, wenn nach einem Update so gut wie nichts mehr geht.

    Zumal der Support via Remote ganz locker auf den Hostserver kann und dort die Einstellungen Prüfen kann, da die vServer auf dem Hostserver verwaltet werden, also ein paar klicks und man könnte sicher den Fehler finden.

    Anderen falls, wenn der Server läuft, Backup machen, Server neu aufsetzen = löst zu 99% alle Probleme.
    Ihr sucht Webspace für eure Projekte? Dann sagt bescheid - kostenfrei und ohne Werbung!
    ​Anderen falls, wenn der Server läuft, Backup machen, Server neu aufsetzen = löst zu 99% alle Probleme.

    Nein, du setzt einen Server auf, damit ist aber ja das Problem nicht gelöst.

    ​So webseite und alles ging wieder , jedoch ist nach einiger Zeit wieder alles abgestürzt

    Mit "nach einiger Zeit" sind die 1,5 Stunden zwischen deinem vorletzten und letzten Beitrag gemeint?

    Über ein paar mehr Infos würde ich mich schon freuen ...

    Link :thumbup:


    www.marius-gerum.de
    PHP lernen | Programmierung | Sonstiger Krempel
    Zum Blog | PHP lernen | GitHub | Gists | List of awesome

    Hmhm.

    Klingt für mich alles wie nach falsch Konfiguriert.
    Hast du denn die ganzen Grundkenntnisse um den Server überhaupt zu betreiben oder fehlt das komplett?
    Falls es fehlt warum holt man sich denn gleich einen Server? Hätte es nicht ein Webspace auch getan?
    Villt sich dann eine kleine VM aufsetzten und ein bissl rumspielen + lernen. Ist alles besser als das es dann im Livebetrieb
    schief geht weil man keine Ahnung hat.

    Sorry für die harten Worte aber ich frage mich immer wieder warum man sich einen Server holt wenn man offensichtlich
    keine Ahnung von der Materie hat. Vor allem sei noch angemerkt wenn dein Server mal "mist" bauen sollte haftest du selbst dafür nicht
    dein Hoster sondern du.
    Grüße , xChRoNiKx
    Ja ich bin mir bewust mit der Haftung etc. aber das mal ausenweg, ich habe darüber auch IRC, TS3 usw... laufen wenn ich es brauche dafür reicht keine Webspace, der Server ist soweit eingerichtet geworden von jemanden der Aber dafür keine Zeit mehr hat. Wir haben darauf Webseiten laufen und für die Stadt ne Seite daher dringlichkeit das alles läuft.

    Sagen wir 5min ist der Server gelaufen (musste Arbeiten zwischendurch)

    Was ich nicht verstehe Restore von Backup = Server ging 5min
    Neustart = Kein Zuck mehr

    Ich werde mir nochmal jetzt die Logs anschauen vom Server nun solte er was Protokolliert haben denke ich.

    Die einzigsten Logs von 07.06 sind folgend :

    Quellcode

    1. ===> Wed Jun 7 18:08:56 CEST 2017, args: status
    2. * sw-engine-fpm is not running
    3. ===> Wed Jun 7 18:13:17 CEST 2017, args: status
    4. * sw-engine-fpm is not running
    5. Upstart :
    6. [07-Jun-2017 13:19:32] ERROR: failed to post process the configuration
    7. [07-Jun-2017 13:19:32] ERROR: FPM initialization failed
    8. [07-Jun-2017 13:19:32] ERROR: No pool defined. at least one pool section must be specified in config file
    9. [07-Jun-2017 13:19:32] ERROR: failed to post process the configuration
    10. [07-Jun-2017 13:19:41] NOTICE: fpm is running, pid 1954
    11. [07-Jun-2017 13:19:41] NOTICE: ready to handle connections
    12. [07-Jun-2017 13:19:41] NOTICE: configuration file /etc/sw-engine/sw-engine-fpm.conf test is successful
    13. [07-Jun-2017 13:30:50] NOTICE: Terminating ...
    14. [07-Jun-2017 13:30:50] NOTICE: exiting, bye-bye!
    15. Jun 7 13:30:15 h257740 postfix/cleanup[2236]: warning: mail_queue_enter: create file incoming/402925.2236: Disk quota exceeded


    Ich denke irgendwas bei Plesk ist zerschossen durch irgendein Update

    boot.log ist leer ?!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Saphira104“ ()

    Zeile 20 sagt doch alles. Der dir zugewiesene Speicher ist randvoll ("disk quota exceeded"). Das heißt du hast zuviel shit gespeichert oder (was ich eher vermute) durch das Update durch Strato (mit möglicherweise einhergehenden Updates von Modulen und Komponenten die deinen Webserver betreffen) wurde der Speicher bis zum Ende hin vollgeladen. Wobei das in dem Fall auch nur die Postfächer betreffen kann (Stichwort Postfix), was dann ja nur damit zu tun hätte dass zuwenig Speicher dafür zugewiesen ist, das muss nicht heißen dass der Speicher generell voll ist.
    Bzgl. FPM würde ich -falls es Probleme macht- auf FastCGI switchen.

    Link :thumbup:


    www.marius-gerum.de
    PHP lernen | Programmierung | Sonstiger Krempel
    Zum Blog | PHP lernen | GitHub | Gists | List of awesome

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Link“ ()

    Saphira104 schrieb:

    der Server ist soweit eingerichtet geworden von jemanden der Aber dafür keine Zeit mehr hat. Wir haben darauf Webseiten laufen und für die Stadt ne Seite daher dringlichkeit das alles läuft.


    Hm.. nix für ungut. Aber wenn da auch wirklich Seiten drauf laufen, die eine "gewisse" Verfügbarkeit erwarten sollten.. dann sollte da jemand mit Verständnis kurzfristig übernehmen.
    Wenn dieser "jemand" kurzfristig ausgestiegen ist, dann besser einen kurzfristig vielleicht teuren Freelancer ins Boot holen, als möglicherweise einen potenten (oder mehrere) Kunden zu verlieren.

    Zu der Fehlermeldung ist ja bereits alles gesagt. Wenn jemand diese nicht versteht.. naja, da ist da ein Bedarf. Würde ich zumindest mal vorsichtig formulieren.

    Gute Grüße

    Neu

    13 Tage sind nun vergangen, seit deinem letzten Post zum Thema.. also alles nicht so dringend ;) . Das ist doch schon mal gut.

    Was zeigt dir ein

    Quellcode

    1. df -h


    Und was beinhaltet eigentlich /repair? Da steht doch das dieser mountpoint massig inodes schluckt?

    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „wertherchen“ ()