Browser öffnet bestimmte Website nicht?

  • VB.NET

Es gibt 6 Antworten in diesem Thema. Der letzte Beitrag () ist von Bazz_MuTTanTT.

    Browser öffnet bestimmte Website nicht?

    Hi,

    ich möchte in einem Webbrowser eine bestimmte Website öffnen (https:\\) jedoch gibt mit der Webbrowser immer den fehler "404" aus.
    Er konnte demzufolge also die Website finden, den gesuchten Link jedoch nicht.
    Da es sich jedoch um die Startseite handelt und exakt der gleiche URL auch im IE und auf Firefox funktioniert, weiß ich nicht woran es noch liegen könnte.

    Die Seite wird ganz normal mit dem üblichen Code aufgerufen.

    Quellcode

    1. Webbrowser1.url = new Uri("https://website.de")


    Kennt jemand von euch ein ähnliches Problem oder weis Rat? 8|
    Naja ist ja im Endeffekt die gleiche Funktion, aber funktioniert beides nicht.
    Auch Pinganfragen schlagen fehl, also scheint hier irgendwas vor die Website geschaltet zu sein, was den Zugriff aus VB oder CMD unterdrückt.
    Kennt da jemand eine Lösung?

    Edit by hal2000: Vollzitat entfernt.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „hal2000“ ()

    also bei mir macht er es mit

    VB.NET-Quellcode

    1. Me.WebBrowser1.Navigate("www.lala.de")


    ganz normal auf

    um welche URL handelt es sich denn die er bei dir nicht nehmen mag
    If Energy = Low Then
    Drink(aHugeCoffee)
    Else
    Drink(aHugeCoffeeToo)
    End If

    asusdk schrieb:



    um welche URL handelt es sich denn die er bei dir nicht nehmen mag


    Ich versuche es gerade bei reifen24.de, da ich dort hin und wieder etwas auslesen möchte.
    Ich habe eben einen Tipp erhalten, dass es an der Version des IE liegen könnte, da hier minimum IE 9 benötigt wird.
    Dazu auch eine Möglichkeit das IE Control via Registry zu zwingen die neuste Version zu nutzen, doch das funktioniert leider ebenfalls nicht.
    @Bazz_MuTTanTT An der Version Deines Explorer-Programms kann das sehr wohl liegen.
    Ich hab auf einem Steinkohlen-Rechnern noch ein W2000 mit nem alten FireFox drauf.
    Gegen Ende des letzten Jahres sagte er mir bei Aufruf von Freenet.de, dass der Browser veraltet sei.
    Seit diesem Jahr passiert da gar nix mehr.
    Neuer Browser und fein.
    Falls Du diesen Code kopierst, achte auf die C&P-Bremse.
    Jede einzelne Zeile Deines Programms, die Du nicht explizit getestet hast, ist falsch :!:
    Ein guter .NET-Snippetkonverter (der ist verfügbar).
    VB-Fragen über PN / Konversation werden ignoriert!
    *Vollzitat entfernt, bitte auf unsere Regeln achten*

    Hi, lag es auch.
    Die Beschreibung welche ich dazu gefunden hatte war jedoch fehlerhaft.
    In meinem Fall benötigte ich den RegistryKey für 32bit Anwendungen auf einer 64Bit Machine.
    Muss man erstmal wissen, dass das nen Unterschied macht^^

    Hier der Link zu der Website, die mir weitergeholfen hat.
    Funktioniert jetzt spitze

    weblog.west-wind.com/posts/201…Specifying-the-IE-Version

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Marcus Gräfe“ ()