STRG + Enter in VS2015 auf VS2012 anpassen

  • Allgemein

Es gibt 7 Antworten in diesem Thema. Der letzte Beitrag () ist von Nils_Kr.

    STRG + Enter in VS2015 auf VS2012 anpassen

    Hi,

    ich habe jetzt lange mit VS2012 gearbeitet und mich an den Befehl ​STRG+ENTER gewöhnt, welcher den Intenllisensevorschlag auswählt und sonst nichts weiter macht. Bei VS2015 funktioniert das nicht mehr. Jetzt wird mit STRG+Enter eine Zeile oberhalb eingefügt. Wie bekomme ich es hin, dass die Tastenkombination wieder das Verhalten von Vs2012 übernimmt?
    Option strict = on

    If it's stupid and it works it ain't stupid.
    Menü Extras -> Optionen -> Tastatur; dann bei "Tastenkombination drücken" rein und Strg+Enter drücken, dann siehst Du, zu welcher Aktion die Kombi zugeordnet ist. oben über die Suche diese Aktion raussuchen und [Entfernen].
    Ich habe allerdings festgestellt, dass (bei mir) IntelliSense einfach ne Zeit braucht (ca. 1,5 Sekunden), bis es aktiv wird und ich es nutzen kann.

    ##########

    Was sagen die Optionen bei Text-Editor -> (Deine Sprache) -> IntelliSense?

    ich habe nur VS2017CE; Absweichungen nicht ausschließbar
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Häufig von mir verwendete Abkürzungen: CEs = control elements (Labels, Buttons, DGVs, ...) und tDS (typisiertes DataSet)
    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht in den Spekulatiusmodus gehen.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „VaporiZed“ ()

    ah, englisch. "press shortcut keys:", rechts unten;
    Ich seh grad, dass bei Vs2017 IntelliSense auf Alt+Enter "verschoben" wurde
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Häufig von mir verwendete Abkürzungen: CEs = control elements (Labels, Buttons, DGVs, ...) und tDS (typisiertes DataSet)
    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht in den Spekulatiusmodus gehen.
    @Nils_Kr Bietet der 15er an, die Tastenkombinationen vom 12er zu übernehmen?
    Probier mal dies:
    Falls Du diesen Code kopierst, achte auf die C&P-Bremse.
    Jede einzelne Zeile Deines Programms, die Du nicht explizit getestet hast, ist falsch :!:
    Ein guter .NET-Snippetkonverter (der ist verfügbar).
    VB-Fragen über PN / Konversation werden ignoriert!
    das kann ich leider nicht ausprobieren, da der Rechner mit VS2012 in der Firma steht und der mit VS2015 bei mir zu Hause.

    Ich hab jetzt übrigens einfach mal VS2017 installiert (deutsch), aber die Problematik ist natürlich die gleiche :D

    STRG+ENTER hab ich aus den Hotkeys entfernt, jetzt müsste ich nur den Namen des Befehls wissen, mit dem man die Intellisense Auswahl bestätigt.

    PS: Unter den Intellisense-Einstellungen kann man auswählen, was passiert, wenn man Enter drückt. Ob neue Zeile oder nicht.

    PS2: bearbeiten.WortVervollständigen funktioniert, wenn die Zeile mit Intellisense abgeschlossen werden kann. Also aus color.re + STRG+ENTER wird Color.Red gemacht und es wird nicht in eine neue Zeile gesprungen. Habe ich aber col und drücke STRG+ENTER passiert nichts, bei VS2012 würde der Editor Color. vervollständigen und dann Farben vorschlagen.
    Option strict = on

    If it's stupid and it works it ain't stupid.

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von „Nils_Kr“ ()

    Nils_Kr schrieb:

    da der Rechner mit VS2012 in der Firma steht und der mit VS2015 bei mir zu Hause.
    Dann speicherst Du die Einstellungen während der Arbeitszeit auf nem Stick und lädtst sie zu Hause rein. ;)
    Falls Du diesen Code kopierst, achte auf die C&P-Bremse.
    Jede einzelne Zeile Deines Programms, die Du nicht explizit getestet hast, ist falsch :!:
    Ein guter .NET-Snippetkonverter (der ist verfügbar).
    VB-Fragen über PN / Konversation werden ignoriert!
    Das werde ich auch heute machen, nur ging das gestern schlecht ^^

    PS: Sollte das trotzdem nicht funktionieren, werde ich mich wahrscheinlich mit der Einstellung abfinden, dass Enter für IntelliSense und neue Zeile gewählt ist und das Programm je nach Situation eins davon wählt. Ist nur etwas ätzend, wenn man andauernd Strg+Enter drückt und nichts passiert.
    Option strict = on

    If it's stupid and it works it ain't stupid.