Problem beim Einbinden eines Datasets

  • VB.NET
  • .NET 4.5

Es gibt 4 Antworten in diesem Thema. Der letzte Beitrag () ist von Schoofi.

    Problem beim Einbinden eines Datasets

    Ich habe ein Projekt, in das mehrere Datasets eingebunden sind.
    Ein Dataset wird in der Entwicklerumgebung nicht erkannt. Ich muß es jedes mal aus dem Projekt ausschließen und danach wieder hinzufügen.
    Dannn funktioniert es bis zum nächsten Start von Visual Studio.
    Wie kann ich das dauerhaft reparieren ?
    Ein Projekt mit mehreren tDSs? Ist das zwangsläufig notwendig?
    Falls ja, erstmal ein Backup machen.
    Dann würd ich es so schrittweise probieren:
    1. Projekt bereinigen und neu kompilieren
    2. Designer.VB-Datei des betroffenen löschen und neu kompilieren
    3. alle Tabellen + Relationen im Designer des betroffenen tDS markieren, ausschneiden, und im selben tDS-Designer wieder einfügen
    4. ein neues tDS anlegen, den tDS-Designer-Inhalt des fehlerhaften in das neue kopieren, das alte löschen und das neue umbenennen in das alte. Wer weiß, wo sich da VS verhaspelt.
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Häufig von mir verwendete Abkürzungen: CEs = control elements (Labels, Buttons, DGVs, ...) und tDS (typisiertes DataSet)
    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht in den Spekulatiusmodus gehen.
    Das sollte sich im tDS-Designer abändern lassen, indem Du dort ins Eigenschaftenfenster gehst, dort das tDS an sich auswählst und dessen Name-Property veränderst.
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Häufig von mir verwendete Abkürzungen: CEs = control elements (Labels, Buttons, DGVs, ...) und tDS (typisiertes DataSet)
    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht in den Spekulatiusmodus gehen.
    Das hatte ich getan, ohne Erfolg. Habe aber die Designerdatei wieder zurückgespielt und siehe da der Name stimmte wieder.
    Allerdings sind mir unterwegs alle Fieldexpressions verlorengegangen.
    Aber ich hoffe, dass es wenn die nachgepflegt sind, alles wieder ordnungsgemäß funzt.

    Ganz leise Hoffnung habe ich das sich vielleicht auch mein Problem mit der Parallelitätsverletzung nach Neuanlegen und sofortigen ändern eines Datensatzes gegeben hat.
    Aber das werde ich sehen.