Visual Studi 2017: Probleme mit der Vervollständigung

  • VB.NET
  • .NET 4.0

Es gibt 8 Antworten in diesem Thema. Der letzte Beitrag () ist von Bibi.

    Visual Studi 2017: Probleme mit der Vervollständigung

    Neuer Laptop, die Entwicklungskomponenten neu installiert und schon funktioniert vieles nicht mehr so, wie man es kennt.
    Oft sind es nur kleine Details, die vermutlich irgendwo in den Optionen zu finden sind. Aber diese Details verzögern die Geschwindigkeit und den Komfort bei der Entwicklung.
    Und genau hier liegt mein Problem, seit ich auf meinem neuen Laptop Visual Studio 2017 Professionell installiert habe, funktioniert die Code-Vervollständigung nicht so, wie ich es sonst kenne. Wenn ich richtig liege, sind die Einstellungen über IntellSence vorzunehmen aber ich finde keinen passenden Punkt.

    Das Problem ist folgendes. Wenn ich die Vervollständigung erhalte, dann zeigt der mir sämtlichen Informationen an, durch die ich ewig lang durchscrollen kann und nicht hilfreich sein.
    Benötigt werden aber nur Methoden und Parameter/Variablen. So, wie es sonst der Fall war. Wenn ich allerdings auf die beiden Knöpfe (1 und 2 beim Screenshot) klicke, wird mir genau das angezeigt, was ich benötige. Allerdings muss ich diese JEDES Mal neu setzen. Kann man diese nicht irgendwo vorbelegen, damit man es nicht ständig eingeben muss?


    Ich bedanke mich für die Hilfe
    @Bibi Geh zu Deinem alten Rechner, exportiere die Einstellungen und importiere sie am Laptop.
    Falls Du diesen Code kopierst, achte auf die C&P-Bremse.
    Jede einzelne Zeile Deines Programms, die Du nicht explizit getestet hast, ist falsch :!:
    Ein guter .NET-Snippetkonverter (der ist verfügbar).
    VB-Fragen über PN / Konversation werden ignoriert!
    Entschuldige bitte die späte Reaktion.

    RodFromGermany schrieb:

    @Bibi Geh zu Deinem alten Rechner, exportiere die Einstellungen und importiere sie am Laptop.

    Hallo,
    habe ich gemacht, dennoch hat es leider keinen Erfolg gebracht.

    Lokal habe ich das Visual Studio 2015 und 2017 installiert.
    Bei VS2015 habe ich besagte Probleme nicht, dort gibt es auch überhaupt nicht den Filter und mir werden eh nur die vorhanden Parameter und Methoden angezeigt.
    In VS2017 wird mir sämtliches angezeigt, was auch ständig zu ungewollten Code-Vervollständigungen führt und sehr hinderlich beim Entwickeln ist.

    Hat jemand eine Idee, wie ich das in VS2017 abstellen kann?

    Danke sehr
    Hallo

    Optionen -> TextEditor -> Basic -> Intellisense und dort den Haken bei "Vervollständigungsfilter anzeigen" raus.

    Grüße
    Sascha
    If _work = worktype.hard Then Me.Drink(Coffee)
    Seht euch auch meine Tutorialreihe <WPF Lernen/> an oder abonniert meinen YouTube Kanal.

    ## Bitte markiere einen Thread als "Erledigt" wenn deine Frage beantwortet wurde. ##

    Nofear23m schrieb:

    Hallo

    Optionen -> TextEditor -> Basic -> Intellisense und dort den Haken bei "Vervollständigungsfilter anzeigen" raus.

    Hallo Sascha,
    danke dir für die Hilfe.
    Die Einstellung habe ich auch schon gefunden, allerdings löst es das Problem nicht.
    Der Filter ist nicht das Problem, sondern das dort die "Codeausschnitte" mit angezeigt werden. Und jedes Mal, wenn man gerade eine Variable deklariert und nach dem AS das Leerzeichen drückt, wird direkt einer der Codeausschnitte in den Quellcode geworfen. Unglaublich nervig.

    Mittlerweile bin ich hingegangen und habe alles aus dem Ordner "C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise\VB\Snippets" rausgeworfen (natürlich vorher ein Backup gemacht). Und da es keine Codeausschnitte mehr gibt, werden diese (und dessen Filter-Option) auch nicht mehr angezeigt.

    Ärgerlich an dem ganzen ist jetzt nur, dass ich die Codeausschnitte nun auch nicht an anderer Stelle nutzen kann.
    Das kann ja irgendwie auch nicht die Lösung sein.

    Bibi schrieb:

    Ärgerlich an dem ganzen ist jetzt nur, dass ich die Codeausschnitte nun auch nicht an anderer Stelle nutzen kann.

    Was logisch ist.

    Aber das ist eben Intellisense. Ich finde es ja gut das es mir die CodeSnippet Shortcuts anzeigt.
    Dem kannst du teilweise entgegenwirken wenn du mit Namespaces arbeitest.

    Ansonsten würde ich sagen. "Its not a bug, its a feature"

    Grüße
    Sascha
    If _work = worktype.hard Then Me.Drink(Coffee)
    Seht euch auch meine Tutorialreihe <WPF Lernen/> an oder abonniert meinen YouTube Kanal.

    ## Bitte markiere einen Thread als "Erledigt" wenn deine Frage beantwortet wurde. ##

    Logisch das die Codeausschnitte nicht mehr genutzt werden können, wenn sie gelöscht werden :D

    Ich kann mir nur beim besten willen nicht vorstellen, dass diese Feature so gewollt bzw. nicht hinderlich ist.
    Wenn ich ein Objekt einer Klasse aufrufe und mir mit dem "." die Methoden und Parameter anschauen will, da haben die Codeausschnitte nichts verloren. Genauso wenig, wenn ich eine Variable deklarieren will und mir dadurch durchweg Code in den Quellcode geworfen wird, noch bevor ich die Deklaration mit string/integer beenden kann.

    Schließlich kann ich die Codeausschnitte an diversen Stellen aufrufen, nur hier war es vorher nie der Fall.
    Wenn man die dort separat deaktivieren könnte, wäre das toll.

    Selbstverständlich danke ich dir für die Hilfe :)
    Habs gefunden:

    Optionen -> Text-Editor -> Basic -> Intellisense -> im Bereich "Ausschnittverhalten" auf "Ausschnitte einschliessen wenn TAB .....

    so kanst du immernoch jederzeit die Codeausschnitte mit ? + TAB aufrufen.

    Grüße
    Sascha
    If _work = worktype.hard Then Me.Drink(Coffee)
    Seht euch auch meine Tutorialreihe <WPF Lernen/> an oder abonniert meinen YouTube Kanal.

    ## Bitte markiere einen Thread als "Erledigt" wenn deine Frage beantwortet wurde. ##

    Nofear23m schrieb:

    Optionen -> Text-Editor -> Basic -> Intellisense -> im Bereich "Ausschnittverhalten" auf "Ausschnitte einschliessen wenn TAB .....

    Das war es, perfekt. Danke
    Ich bin gerade ein wenig irritiert, weil ich mir sicher war, diese Einstellung vorher einmal ohne Erfolg getestet zu haben.

    Ich danke dir, klasse :)