Problem mit der vb-Express-2013 Entwicklungsumgebung

  • .NET 4.5
  • VB.NET

Es gibt 3 Antworten in diesem Thema. Der letzte Beitrag () ist von artnat.

    Problem mit der vb-Express-2013 Entwicklungsumgebung

    Ich muss leider zugeben, die Entwicklungsumgebung ist mir weitgehend schleierhaft.

    Ich habe ein Programm entwickelt, das im Debug-Mode gut lief. Ich weiß nicht, womit ich es erreicht habe, dass es neuerdings nicht recht starten will, weil es zwei Fehlermeldungen zeigt, allerdings erst nach Start des Programms, keine eigentlichen Fehler im Code. Hier die Fehlermeldungen:

    "obj\x86\Debug\farbbildstruktur.exe konnte nicht in "bin\Debug\farbbildstruktur.exe" kopiert werden. Die zulässige Anzahl von Wiederholungen von 10 wurde überschritten. Fehler.

    Die zweite Fehlermeldung:

    Die Datei "obj\x86\Debug\farbbildstruktur.exe kann nicht in "bin\Debug\farbbildstruktur.exe" kopiert werden. Der Prozess kann nicht auf die Datei "bin\Debug\farbbildstruktur.exe" zugreifen, da sie von einem anderen Prozess verwendet wird.

    Es läuft allerdings kein anderes Programm, jedenfalls keines, das ich gestartet habe. Es läuft nur die Entwicklungsumgebung. Ich habe keine Ahnung, wie ich dieses Problem wieder loswerde.

    Thema verschoben ~VaporiZed

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „VaporiZed“ ()

    Das habe ich in 2 Fällen bisher gehabt.
    1. Das Programm läuft noch als 2. Instanz als Exe und kann daher nicht nochmal erstellt werden, weil die Exe nicht überschrieben werden kann. Leicht nachzuvollziehen, wenn Du ins Debug-Verzeichnis gehst und versucht, die Exe manuell zu löschen.
    2. (D)ein Virenscanner o.ä. verhindert (aufgrund neuer Signaturen?) den Zugriff auf die Exe, weil sie als Problem erkannt wird bzw. das Scanprogramm die Exe in Quarantäne schieben wird. Geh offline, schalt die Antivirenprogramme kurzfristig ab und probier es nochmal.
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht den Spekulatiusbackmodus wechseln.
    @artnat Der 10-Mal-Kopierfehler kam bei mir meist dann, wenn im Editor eine Form oder ein UserControl im Designer geöffnet war.
    Schließe die vor dem Compilieren und gut.
    Mit dem Virenscanner hat das nix zu tun.
    Und:
    Hole Dir eine neuere Entwicklungsumgebung, kostenlos:
    chip.de/downloads/Visual-Studio-2019-Community_36594360.html
    Falls Du diesen Code kopierst, achte auf die C&P-Bremse.
    Jede einzelne Zeile Deines Programms, die Du nicht explizit getestet hast, ist falsch :!:
    Ein guter .NET-Snippetkonverter (der ist verfügbar).
    Programmierfragen über PN / Konversation werden ignoriert!