VSE 2013 Subs plötzlich einzeln statt gesamtes Modul

  • VB.NET

Es gibt 8 Antworten in diesem Thema. Der letzte Beitrag () ist von Kaypetri.

    VSE 2013 Subs plötzlich einzeln statt gesamtes Modul

    Hallo zusammen Ihr Profis. Ich habe seit langen mal wieder ein unerklärliches Problem.
    Ich habe ein Projekt das ich ein ein und dem selben Modul geschrieben habe mit verschiedenen Subs drin, public und private.

    Ein paar Stunden später hatte ich damals das Projekt nochmal bearbeitet und auch debugt. Heute wollte ich daran ein weiteres update einfügen und stelle plötzlich fest das teilweise die Subs plötzlich einzelne Module sind. Ich habe jetzt versucht damit zurecht zu kommen, aber ich bin ehrlich. Hier komme ich nicht mehr klar, da in den einzelnen Modulen nicht alles dargestellt ist was eigentlich dafür nötig ist. Es fehlen also Codezeilen die dann allerdings in einem anderen Modul vorkommen und irgendwie scheint er das auch zu checken.
    Im Projektordner sin die Module auch plötzlich als einzelne Module aufgelistet, das ist beim alten nicht so, da gibt es nur das eine Modul.

    Hat jemand eine Idee wie ich das wieder zu einem Modul zusammenfassen kann? ODer evtl. kann mir jemand auf die Sprünge helfen was ich sonst noch tun kann, damit ein nicht Profi wie ich damit wieder zurecht kommt.

    Danke und Gruß
    Bilder
    • VSE_MODULFEHLER_1.JPG

      185,21 kB, 1.670×709, 24 mal angesehen
    • VSE_MODULFEHLER_2.JPG

      102,8 kB, 1.315×519, 22 mal angesehen

    Kaypetri schrieb:

    Hat jemand eine Idee wie ich das wieder zu einem Modul zusammenfassen kann? ODer evtl. kann mir jemand auf die Sprünge helfen was ich sonst noch tun kann, damit ein nicht Profi wie ich damit wieder zurecht kommt.


    Profi werden!

    Nein, kleiner Witz, aber wenn du den ursrünglichen Code geschrieben hast, weshalb bist du nicht in der Lage den wiederherzustellen in dem du wieder alles von Hand in ein Module reinmachst? Sind doch "nur" 8 Dateien, via Copy und Paste sollte das in weniger als 2 Minuten erledigt sein. Wie soll das den passiert sein, das plötzlich alles in einzelnen Dateien ist? Von allein hab ich sowas nie erlebt. Irgendeine Info gibst du uns scheinbar nicht. Ist sogar das erste mal das ich sowas lese.

    Das finde ich ja noch Mysteriöser als das mit VaporiZed's Glaskugeln, die der Hersteller wohl nicht mehr zurück schickt.
    Die Natur ist bekanntermaßen knallhart, sie sortiert aus was sich nicht bewährt hat.(Harald Lesch, 2021)

    Demnach müssten wir bald dran sein...
    Wie gesagt, ich weis nicht wie das entstanden ist. Ich habe da nichts bewusst gemacht. Einfach copy/paste geht leider nicht, da die Module nicht so da sind wie die subs ursprünglich waren. Sprich im Modul mFertigmelden sind plötzlich Zeilen welche eigentlich zum mConnection gehören. Auch müsste dort drin eine IF-Abfrage stehen, die wird garnicht aufgeführt. Ich checke das einfach nicht warum da so ein kuddelmuddel drin ist. Im Screenshot kannst Du sehen das im ersten eigentlich 3 Zeilen benötigt werden und im 2. Screenschot bei Connection plötzlich nur 2 dargestellt sind. Die Dritte befindet sich plötzlich in einem anderen Modul.
    Ich glaube immer noch nicht das das einfach so passiert ist. Du hast mehrere Optionen. Dich in diesen Code einarbeiten und so verwenden wie er ist. Alles von Hand wieder in 1 Module machen, wenn du den Code wirklich selbst geschrieben hast, musst du ihn kennen, wie auch wissen was wo los ist, sollte also eigendlich kein Problem sein, ich sehe da überhaupt kein Problem.

    Eine weitere Option wäre der Marktplatz/die Jobbörse hier im Forum, viel ist's ja nicht, vllt. macht dir das jemand für 'nen kleinen Obulus.

    Wenn du es wieder in einem Module haben willst ohne die Option mit der Jobbörse, fang an, wenn du irgendwo feststeckst warum auch immer, frag gezielt nach, warum, weswegen was so ist.
    Die Natur ist bekanntermaßen knallhart, sie sortiert aus was sich nicht bewährt hat.(Harald Lesch, 2021)

    Demnach müssten wir bald dran sein...
    Ja, das ist am Ende die Option, es hätte ja sein können das es eine Möglichkeit gibt, das VS das wieder in korrekte Reihenfolge bringen kann. Es ist mir einfach ein Rätsel. Selbst wenn ich das absichtlich gemacht hätte, dann würde ich das nie und nimmer so sortieren. Den Code kenne ich. Die letzte Bearbeitung ist allerdings schon 2,5 Jahre her, von daher muss ich mich da schon auch wieder rein denken. Es wird tricky.
    Kurze Zwischenfrage: Wie kommen die 2 Screenshots zustande? Wenn Bild 1 den ursprünglichen, aber verlorenen Zustand anzeigt, wie wurde dann der Screenshot erstellt?


    @Takafusa: Der Glaskugelhersteller hat Insolvenz angemeldet und ist ins Ausland geflüchtet. Der Support ist nicht mehr erreichbar. Zum Glück habe ich den alten Vertrag mit dem Spekulatiushersteller noch aufrechterhalten. :P
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht den Spekulatiusbackmodus wechseln.
    Nein, es gab einen Stand am Morgen des Tages und dann hatte ich eine davon eine Kopie des Ordners gemacht um eine neue Funktion einzuarbeiten am Nachmittag. Daher kann ich jetzt auch die beiden Shoots machen. Die Zeigen im Grunde wie die Struktur am Morgen waren und nach der Kopie am Nachmittag. Ich bin mir aber auch zu 100% sicher das ich ursprünglich im System wie am Morgen gearbeitet habe, weil so wie es jetzt ist, ja auch garkeinen Sinn macht.
    Wenn Du die Sicherungskopie hast, nutze sie. Eine plötzliche Änderung der Projektstruktur (Erstellung von zusätzlichen Dateien passieren selten von allein, vor allem mit solchen Namen nicht!) von Vormittag auf Nachmittag klingt entweder nach Amnesie oder heimlichen Mitbearbeitern.
    Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von „VaporiZed“, mal wieder aus Grammatikgründen.

    Aufgrund spontaner Selbsteintrübung sind all meine Glaskugeln beim Hersteller. Lasst mich daher bitte nicht den Spekulatiusbackmodus wechseln.
    Wie gesagt, das was jetzt als Module angelegt ist, waren ursprünglich Subs. Egal, dann muss ich das überarbeiten. Hätte ja durchaus sein können das es hier einfach ein Funktion im VS gibt mit welcher man da was machen kann. Ich habe da definitv nichts selber verschoben, angelegt oder sonst was gemacht, auch wenn das jetzt für euch erstmal nicht so aussehen mag.