Nach Umstellung Website Probleme mit ttsmp3.com im Webbrowser Control

  • VB.NET
  • .NET (FX) 4.5–4.8

Es gibt 1 Antwort in diesem Thema. Der letzte Beitrag () ist von slice.

    Nach Umstellung Website Probleme mit ttsmp3.com im Webbrowser Control

    Hallo zusammen,

    erstmal möchte ich mich vorstellen, bin 51 Jahre jung, hauptberuflich CNC Programmierer und habe nach einiger Turbo Pascal/VB6 Erfahrung in den 90ern vor ca. 3 Jahren angefangen mich mit VB.NET zu beschäftigen.

    Nun zum Problem, an welchem ich nun 2 Wochen hänge und einfach nicht weiter komme.
    Im Rahmen eines größeren Projekts greife ich über ein Webbrowser Control auf die Seite ttsmp3.com zu, um bei Bedarf eine Sprachausgabe mit einer besseren Stimme als die Windows Sprachausgabe zu nutzen.
    Das Ganze hat auch monatelang wunderbar funktioniert, bis Anfang Januar die Website geändert wurde. egal ob ich den READ Button per Maus klicke oder über InvokeMember("click"), der Klick wird ausgeführt aber der Text nicht mehr gelesen, sondern die Seite neu geladen.
    Die Registry Einträge damit das Webbrowser Control den aktuellen Edge benutzt sind gesetzt. Betriebssystem ist Windows 10 mit VS2019
    Da ich absolut keinen Plan von Webseitenprogrammierung habe, weiß ich hier nicht weiter.

    Das folgende Codeschnipsel ist auf das eigentliche Problem runtergebrochen.
    (ein Webbrowser Control und drei Button)

    VB.NET-Quellcode

    1. Private Sub Button1_Click(sender As Object, e As EventArgs) Handles Button1.Click
    2. WebBrowser1.Navigate("ttsmp3.com")
    3. End Sub
    4. Private Sub Button2_Click(sender As Object, e As EventArgs) Handles Button2.Click
    5. WebBrowser1.Document.GetElementById("voicetext").Focus()
    6. WebBrowser1.Document.GetElementById("voicetext").InnerText = "hallo"
    7. WebBrowser1.Document.GetElementById("vorlesenbutton").Focus()
    8. 'bis hierhin okay
    9. End Sub
    10. Private Sub Button3_Click(sender As Object, e As EventArgs) Handles Button3.Click
    11. 'ging ein paar Monate gut. aber jetzt funktioniert es nicht mehr, Seite wird stattdessen neu geladen
    12. WebBrowser1.Document.GetElementById("vorlesenbutton").InvokeMember("click")
    13. End Sub
    14. End Class



    Wo könnte hier das Problem liegen?

    Gruß
    der Heini

    *Code-BBCode eingefügt, bitte demnächst selbst machen*

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Marcus Gräfe“ ()

    Ich hab mir die Seite nur ganz kurz angeschaut, die benutzten auf der Form onsubmit="return dontsubmit();" was dann den "Senden"-Prozess unterbricht.
    Da sich die Seite bei dir neu lädt, tippe ich auf ein Problem mit dem JavaScript.

    Bist du dir sicher, das du den neuen Edge der auf Chromium basiert benutzt und nicht eventuell den alten mit EdgeHTML oder schlimmer noch, IE?

    Alternativ:
    Hast du dir mal WebView2 oder CEFSharp angeschaut?