[Ubuntu] Statische IP im Netzwerk

Es gibt 27 Antworten in diesem Thema. Der letzte Beitrag () ist von Manawyrm.

    [Ubuntu] Statische IP im Netzwerk

    Hey,

    erstmal vielen Dank für die Antworten in meinem letzten Thread. Ich habe eigentlich alles hinbekommen und muss das komplette System wegen diesem einen Fehler neu aufsetzen.. Ich hab im Internet nach Möglichkeiten gesucht, wie man unter Ubuntu eine statische IP Adresse verteilen kann. Mein Router sollte das eigentlich auch unterstützen. Als Gateway habe ich immer meinen Router angegeben (192.168.2.1), als Maske 255.255.255.0, Broadcast auf 192.168.2.255 und die Adresse selbst auf 192.168.2.2. Der Begriff "Maske" und "Broadcast" sind mir in dem Zusammenhang unbekannt. Naja, das hat alles nicht funktioniert. Irgendwann habe ich dann gelesen, dass ich den Gnome Netzwerkmanager deinstallieren soll. Also hab ich das gemacht und jetzt geht garnichts mehr. Installieren kann ich ihn logischerweise nicht wieder, weil ich ja kein Internet hab :D

    Ich brauche, wie ihr sicher sehen könnt Hilfe, am Besten detailiert :) und ich hoffe, dass ihr mir nicht Böse seit, dass ich das hier poste. Ich möchte nicht noch ein Forum suchen, das eventuell eine ähnliche Qualität wie dieses besitz.


    Danke für eure Antworten!
    Der Router sagt ja:


    Subnetzmaske: 255.255.255.0


    Ich habe generell ja keine Ahnung von Linux. Ich hab mich heute das erste mal intensiver damit beschäftigt und mir die Basics der Basics angeeignet.

    Das war übrigends der Inhalt der "interfaces" + dem oberen Teil, der Standartmäßig drinnen war:


    auto lo
    iface lo inet loopback
    auto eth0
    iface eth0 inet static
    address 192.168.2.2
    network 192.168.2.0
    netmask 255.255.255.0
    broadcast 192.168.2.255
    gateway 192.168.2.1
    Ich kann das im Moment nicht sagen. Ich setze grad Ubuntu neu auf. Sobald es fertig ist, ändere ich die interfaces Datei nochmal und poste die Ergebnisse!

    So die gesamte Ausgabe:

    system@Media-Server:/$ ip addr show dev eth0
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:22:68:49:57:dc brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.108/24 brd 192.168.2.255 scope global eth0
    inet 192.168.2.2/24 brd 192.168.2.255 scope global secondary eth0
    inet6 fe80::222:68ff:fe49:57dc/64 scope link
    valid_lft forever preferred_lft forever
    system@Media-Server:/$
    system@Media-Server:/$
    system@Media-Server:/$ ip route show
    default via 192.168.2.1 dev eth0 proto static
    default via 192.168.2.1 dev eth0 metric 100
    169.254.0.0/16 dev eth0 scope link metric 1000
    192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.108 metric 1
    system@Media-Server:/$
    system@Media-Server:/$
    system@Media-Server:/$
    system@Media-Server:/$ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    search Speedport_W723_V_Typ_A_1_00_092
    system@Media-Server:/$



    EDIT Die Ausgabe hat nicht gestimmt. Ich bearbeite sie kurz. Moment

    Das ist die richtige Ausgabe (allerdings hat man mit diesen Einstellungen kein Internet) :

    system@Media-Server:/$ ip addr show dev eth0
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:22:68:49:57:dc brd ff:ff:ff:ff:ff:ff
    inet 192.168.2.2/24 brd 192.168.2.255 scope global eth0
    inet6 fe80::222:68ff:fe49:57dc/64 scope link
    valid_lft forever preferred_lft forever
    system@Media-Server:/$ ip route show
    default via 192.168.2.1 dev eth0 metric 100
    169.254.0.0/16 dev eth0 scope link metric 1000
    192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.2
    system@Media-Server:/$ cat etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    system@Media-Server:/$

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von „Cubysoft“ ()

    Das sieht soweit gut aus, nur fehlt der DNS-Eintrag. Deine /etc/network/interfaces müsste so aussehen:

    Quellcode

    1. iface eth0 inet static
    2. address 192.168.2.2
    3. netmask 255.255.255.0
    4. gateway 192.168.2.1
    5. dns-nameservers 192.168.2.1
    6. dns-search Speedport_W723_V_Typ_A_1_00_092
    Die letzte Zeile ist optional.

    Ändere die /etc/network/interfaces für eth0 in das, was in diesem Post steht (bzw. füge die beiden DNS-Zeilen hinzu, den Rest hast du offensichtlich schon). Lasse alle anderen Einträge, wie sie sind (insbesondere "auto lo"). Dann: sudo /etc/init.d/networking restart in der Konsole. Danach müsste eigentlich alles gehen. Testen kannst du das mit den Commands "nslookup google.com" (DNS-Test) und dem altbekannten ping.
    Gruß
    hal2000
    So erstmal danke. Auf die Seite bin ich auch gestoßen, war aber recht kompliziert. Ich habe die Interfaces Datei jetzt genau so angepasst, wie du oben beschrieben hast. Aber geholfen hat das nichts. Jetzt bekomme ich wieder im Firefox "Server not found". Ich verzweifle bald. Bis auf den Eintrag DNS-Server hatte ich das ja auch vorher. Kann es vielleicht daran liegen, dass der network-manager-gnome installiert ist?
    Und genau DAS ist der Grund, warum Ubuntu bzw. eine grafische Benutzeroberfläche wie Gnome komplett ungeeignet für ein Serversystem ist.

    Rate mal, warum ich Debian empfohlen habe.
    #define true ((rand() % 2)? true: false) //Happy debugging suckers
    Ich gebe KEINE Hilfe per PN! Es gibt für ALLES nen Forum/Thread!
    Okay ich kanns ja mal testen. Wenn ich ein Paket mit apt-get deinstalliere. Kann ich das dann iwie zwischenspeichern um das Paket später wieder zu installieren?

    Und ja Ubuntu hab ich eigentlich deswegen genommen, weil ich das halt gewöhnt bin, ich hab das damals mal ersatzweise für Windows genutzt.
    Für Desktoprechner ist das ja auch völlig ok, aber für Server oder ähnliches VÖLLIG ungeeignet.

    Gnome-Networkmanager ist ein klasse Programm, aber wirklich nur für Desktop.
    #define true ((rand() % 2)? true: false) //Happy debugging suckers
    Ich gebe KEINE Hilfe per PN! Es gibt für ALLES nen Forum/Thread!
    Okay. Aber das war ja nicht meine Frage. Wie kann ich den Networkmanager deinstallieren aber iwie ein BackUp machen um ihn dann später ohne Internet wieder installieren zu können?

    Achja und ist KDE 4.8 unter Debian dann besser geeignet?

    Cubysoft schrieb:

    Kann es vielleicht daran liegen, dass der network-manager-gnome installiert ist?

    Ja, kann sein. Ich war davon ausgegangen, dass der deinstalliert ist, wie in Post #1 steht. Aber: Normalerweise sollte der keine Probleme machen, denn der NetworkManager kümmert sich normalerweise nur um Interfaces, die nicht in /etc/network/interfaces konfiguriert sind.

    Wenn du die Konfiguration so übernommen hast: Was geben denn die 3 Commands jetzt aus? Mache außerdem folgende 3 einfache Tests:

    Quellcode

    1. ping 192.168.2.1 //Wenn das geht, ist die IP-Adresse richtig konfiguriert.
    2. ping 8.8.4.4 //Wenn das geht, funktioniert das Routing korrekt.
    3. nslookup google.de //Wenn das auch geht, ist das DNS in Ordnung, also muss Firefox ins Internet kommen.

    Kann es sein, dass der Network manager die resolv.conf wieder überschrieben hat, sodass es keinen DNS-Server gibt? Wenn die resolv.conf wieder nur 127.0.0.1 enthält, teste mal folgendes:

    Quellcode

    1. sudo echo "nameserver 192.168.2.1" > /etc/resolv.conf

    Das müsste dich bis zum nächsten Neustart ins Netz bringen.

    Ein Desktop-System auf nem Server ist zwar sinnlos, muss aber trotzdem funktionieren.
    Gruß
    hal2000
    Soll das ein Homeserver sein? Dann hat da eine grafische Oberfläche rein gar nichts verloren.

    Debian mit GUI ist genauso schlim.

    Setz dich hin, machs einfach. Das ist nur Anfangs so grausig.

    Gruß,
    Tobias
    #define true ((rand() % 2)? true: false) //Happy debugging suckers
    Ich gebe KEINE Hilfe per PN! Es gibt für ALLES nen Forum/Thread!
    Okay werde ich dann wohl machen. Den Ubuntu nervt mich jetzt. Wenn ich den nameserver nämlich in die resolv.conf reinschreib komme ich ins Internet und hab die statische IP. Aber sobald ich dann den PC neustarte ist der Eintrag wieder weg, obwohl der Networkmanager weg ist. Naja.

    Wo finde ich denn ein leeres Debian? Also ohne KDE und so?
    Verabschiede dich von der grafischen Oberfläche. Server werden nur mit der Konsole bedient.

    Ich habe mit Ubuntu Server (Ubuntu basiert übrigens auf Debian) gute Erfahrungen gemacht. Mal abgesehen davon, dass bei jedem Upgrade der Distribution das (Software-)RAID nicht mehr gefunden wird, ists ganz in Ordnung. Beim letzten Upgrade auf 12.04 LTS hat es sogar zum erstem Mal automatisch funktioniert. Mit Debian habe ich noch nicht gearbeitet, aber die Unterschiede zu Ubuntu sollten marginal sein. Für einen Heimserver halte ich Ubuntu Server für besser geeignet, denn dort gibt es des Öfteren aktualisierte Versionen von Paketen, was bei Debian nicht der Fall ist. Daher wird Debian auch eingesetzt, wenn am System jahrelang nichts geändert werden soll (außer Sicherheitsupdates, klar), so wie das in großen Firmen (mit vielen Servern) erwünscht ist.

    Ein Kurzvergleich wäre wohl:
    Debian = sehr stabil, aber neue Features kommen erst Jahre später; lange Supportzyklen
    Ubuntu = mehr neue Features, aber dafür kürzere Supportzyklen.

    Da ein Heimanwender eh keinen (kostenpflichtigen!) Support braucht, ist Debian ein wenig Overkill.
    Gruß
    hal2000